TVOIceCandidatePairStats
Objective-C
@interface TVOIceCandidatePairStats : NSObject
Swift
class TVOIceCandidatePairStats : NSObject
TVOIceCandidatePairStats reflects the properties of a Ice candidate pair
-
@brief A boolean to indicate if the candidate pair is active.
Declaration
Objective-C
@property (nonatomic, assign, unsafe_unretained, readonly, getter=isActiveCandidatePair) BOOL activeCandidatePair;Swift
var isActiveCandidatePair: Bool { get } -
@brief The relay protocol.
Declaration
Objective-C
@property (nonatomic, copy, readonly, nullable) NSString *relayProtocol;Swift
var relayProtocol: String? { get } -
@brief The unique identifier used for TVOIceCandidateStats associated with this candidate.
Declaration
Objective-C
@property (nonatomic, copy, readonly, nullable) NSString *transportId;Swift
var transportId: String? { get } -
@brief The unique identifier that is associated to the object that was inspected to produce the Ice candidate attributes for the local candidate associated with this candidate pair.
Declaration
Objective-C
@property (nonatomic, copy, readonly, nullable) NSString *localCandidateId;Swift
var localCandidateId: String? { get } -
@brief The IP address of the local candidate associated with this candidate pair.
Declaration
Objective-C
@property (nonatomic, copy, readonly, nullable) NSString *localCandidateIp;Swift
var localCandidateIp: String? { get } -
@brief The unique identifier that is associated to the object that was inspected to produce the Ice candidate attributes for the remote candidate associated with this candidate pair.
Declaration
Objective-C
@property (nonatomic, copy, readonly, nullable) NSString *remoteCandidateId;Swift
var remoteCandidateId: String? { get } -
@brief The IP address of the remote candidate associated with this candidate pair.
Declaration
Objective-C
@property (nonatomic, copy, readonly, nullable) NSString *remoteCandidateIp;Swift
var remoteCandidateIp: String? { get } -
@brief Represents the state of the checklist for the local and remote candidates in a pair.
Declaration
Objective-C
@property (nonatomic, readonly) TVOIceCandidatePairState state;Swift
var state: TVOIceCandidatePairState { get } -
@brief The priority of the candidate. Priority is calculated as defined in [RFC5245] section 15.1.
Declaration
Objective-C
@property (nonatomic, readonly) uint64_t priority;Swift
var priority: UInt64 { get } -
@brief This booean is related to updating the nominated flag described in Section 7.1.3.2.4 of [ RFC5245].
Declaration
Objective-C
@property (nonatomic, readonly, getter=isNominated) BOOL nominated;Swift
var isNominated: Bool { get } -
@brief Has gotten ACK to an ICE request.
Declaration
Objective-C
@property (nonatomic, readonly, getter=isWriteable) BOOL writeable;Swift
var isWriteable: Bool { get } -
@brief Has gotten a valid incoming ICE request.
Declaration
Objective-C
@property (nonatomic, readonly, getter=isReadable) BOOL readable;Swift
var isReadable: Bool { get } -
@brief Represents the total number of payload bytes sent on this candidate pair, i.e., not including headers or padding.
Declaration
Objective-C
@property (nonatomic, readonly) uint64_t bytesSent;Swift
var bytesSent: UInt64 { get } -
@brief Represents the total number of payload bytes received on this candidate pair, i.e., not including headers or padding.
Declaration
Objective-C
@property (nonatomic, readonly) uint64_t bytesReceived;Swift
var bytesReceived: UInt64 { get } -
@brief Total round trip time.
@discussion Represents the sum of all round trip time measurements in seconds since the beginning of the session, based on both STUN connectivity check [ STUN-PATH-CHAR] responses (responsesReceived) and consent [ RFC7675] responses (consentResponsesReceived). The average round trip time can be computed from totalRoundTripTime by dividing it by (responsesReceived + consentResponsesReceived).
Declaration
Objective-C
@property (nonatomic, readonly) CFTimeInterval totalRoundTripTime;Swift
var totalRoundTripTime: CFTimeInterval { get } -
@brief Current round trip time.
@discussion Represents the latest round trip time measured in seconds, computed from both STUN connectivity checks [STUN-PATH-CHAR] and consent responses [RFC7675].
Declaration
Objective-C
@property (nonatomic, readonly) CFTimeInterval currentRoundTripTime;Swift
var currentRoundTripTime: CFTimeInterval { get } -
@brief Available outgoing bitrate
@discussion It is calculated by the underlying congestion control by combining the available bitrate for all the outgoing RTP streams using this candidate pair. The bitrate measurement does not count the size of the IP or other transport layers like TCP or UDP. It is similar to the TIAS defined in [RFC3890], i.e., it is measured in bits per second and the bitrate is calculated over a 1 second window.
Declaration
Objective-C
@property (nonatomic, readonly) double availableOutgoingBitrate;Swift
var availableOutgoingBitrate: Double { get } -
@brief Available incoming bitrate
@discussion It is calculated by the underlying congestion control by combining the available bitrate for all the incoming RTP streams using this candidate pair. The bitrate measurement does not count the size of the IP or other transport layers like TCP or UDP. It is similar to the TIAS defined in [RFC3890], i.e., it is measured in bits per second and the bitrate is calculated over a 1 second window.
Declaration
Objective-C
@property (nonatomic, readonly) double availableIncomingBitrate;Swift
var availableIncomingBitrate: Double { get } -
@brief Represents the total number of connectivity check requests received (including retransmissions).
Declaration
Objective-C
@property (nonatomic, readonly) uint64_t requestsReceived;Swift
var requestsReceived: UInt64 { get } -
@brief Represents the total number of connectivity check requests sent (not including retransmissions).
Declaration
Objective-C
@property (nonatomic, readonly) uint64_t requestsSent;Swift
var requestsSent: UInt64 { get } -
@brief Represents the total number of connectivity check responses received.
Declaration
Objective-C
@property (nonatomic, readonly) uint64_t responsesReceived;Swift
var responsesReceived: UInt64 { get } -
@brief Represents the total number of connectivity check responses sent.
Declaration
Objective-C
@property (nonatomic, readonly) uint64_t responsesSent;Swift
var responsesSent: UInt64 { get } -
@brief Represents the total number of connectivity check retransmissions received.
Declaration
Objective-C
@property (nonatomic, readonly) uint64_t retransmissionsReceived;Swift
var retransmissionsReceived: UInt64 { get } -
@brief Represents the total number of connectivity check retransmissions sent.
Declaration
Objective-C
@property (nonatomic, readonly) uint64_t retransmissionsSent;Swift
var retransmissionsSent: UInt64 { get } -
@brief Represents the total number of consent requests received.
Declaration
Objective-C
@property (nonatomic, readonly) uint64_t consentRequestsReceived;Swift
var consentRequestsReceived: UInt64 { get } -
@brief Represents the total number of consent requests sent.
Declaration
Objective-C
@property (nonatomic, readonly) uint64_t consentRequestsSent;Swift
var consentRequestsSent: UInt64 { get } -
@brief Represents the total number of consent responses received.
Declaration
Objective-C
@property (nonatomic, readonly) uint64_t consentResponsesReceived;Swift
var consentResponsesReceived: UInt64 { get } -
@brief Represents the total number of consent responses sent.
Declaration
Objective-C
@property (nonatomic, readonly) uint64_t consentResponsesSent;Swift
var consentResponsesSent: UInt64 { get } -
Unavailable
TVOIceCandidatePairStats cannot be created explicitly.
@brief Developers shouldn’t initialize this class directly.
@discussion Ice candidate pair stats cannot be created explicitly.
Declaration
Objective-C
- (null_unspecified instancetype)init;